News: Trouble logging in? Log in from the login page.
May 25, 2019, 04:12:01 am

Author Topic: Intermittent popping sound Quicksand  (Read 1019 times)

0 Members and 1 Guest are viewing this topic.

Offline frank bare

  • Jr. Member
  • **
  • Posts: 21
Intermittent popping sound Quicksand
« on: February 13, 2016, 05:03:05 am »
Just completed build on Quicksand. What is with an occasional popping sound? Rechecked solder joints and re-seated chip.
Amp otherwise performs great!  Paired with Quickie.

Thanks again for your help,
Bare




Offline Natural Sound

  • Sr. Member
  • ****
  • Posts: 848
Re: Intermittent popping sound Quicksand
« Reply #1 on: February 13, 2016, 06:07:02 am »
Maybe the batteries on the quickie or quicksand are low? Voltage starvation could cause pops.

Offline frank bare

  • Jr. Member
  • **
  • Posts: 21
Re: Intermittent popping sound Quicksand
« Reply #2 on: February 14, 2016, 09:28:15 am »
Thanks for the update. The batteries are all new. Perhaps it could be one of the Quickie tubes? It doesnt happen often,
but if I leave it on without music playing I'll get an occasional pop.
Bare

Online Bonzo

  • Full Member
  • ***
  • Posts: 234
  • My name is Marco, best known as Bonzo
Re: Intermittent popping sound Quicksand
« Reply #3 on: February 14, 2016, 10:14:20 am »
I had the same problem.
I had to resolder all the connection for the filament heater and it worked like a charm, untill I discover I have a fault tube socket.
Try to move a bit the tube and see if it causes pops too.

But please, wait also the response of the Bottlehead crew before tryig anything!

Ciao!
Bisogna avere orecchio!