Bottlehead Forum

Bottlehead Kits => Crack => Topic started by: phigits on May 17, 2019, 03:33:32 pm

Title: Speedball D1 & D2 dark - Resolved
Post by: phigits on May 17, 2019, 03:33:32 pm
Meter readings
OA - 69
OB - 40
G - 0
B+ - 79

D1 and D2 LEDs are dark.

The small board readings were fine before the large board was fitted.  Now they are:
OA - 42
1A - 78
B-A/B - 0
IB - 78
OB - 69

I don't see anything obvious so I'm hoping someone can point me in the right direction.
Title: Re: Speedball D1 & D2 dark
Post by: Paul Birkeland on May 17, 2019, 04:06:57 pm
Your TIP50 transistors are improperly mounted and shorting out the HV supply.  Please see the note in enormous text on page 22 and also note that we have a link to a video because it is so critical that these steps are followed carefully.

I would also very, very strongly suspect that you have a PN2907 in backwards on the small board.

-PB
Title: Re: Speedball D1 & D2 dark
Post by: phigits on May 17, 2019, 05:17:47 pm
Damn.  100% ass-backwards on the TIP50's.  Both PN2907 are correct.

Ordering new parts.

Thanks, Paul.
Title: Re: Speedball D1 & D2 dark
Post by: phigits on May 17, 2019, 05:42:08 pm
Wait a minute...the TIP50 transistors look correct.  But I see the D1 and D2 LEDs are upside down...
Title: Re: Speedball D1 & D2 dark
Post by: Deke609 on May 17, 2019, 06:00:28 pm
Maybe post a pic or two of the board just to be sure.  Fresh eyes are better at picking out possible problems.

cheers,

Derek
Title: Re: Speedball D1 & D2 dark
Post by: phigits on May 18, 2019, 08:39:56 am
The LEDs and voltages are ok.  Now I'm just chasing down a buzz in the right channel.  Checking all the joints again.
Title: Re: Speedball D1 & D2 dark
Post by: phigits on May 18, 2019, 10:11:10 am
Found a post from PB where he repaired a buzz in one channel by removing excess solder from the center pin of the RCA jack.  I did that and viola, the buzz is gone.